[UPHPU] PHP Framework Project Launch - Coders welcome to attend

Mac Newbold mac at macnewbold.com
Wed Jun 1 18:00:39 MDT 2005


Today at 4:02pm, Wade Preston Shearer said:

>Bigdog Ray Hunter said:
>> Why do the core in php4 and then some modules in php5? Not sure the
>> reason for using php4 when this is a new project and might benefit from
>> php5.
>
> Agreed. I think that it should be programmed in PHP 5.

The primary reason we decided against PHP 5 is we want the thing to be 
usable on PHP 4 servers, which are still very common. I, for one, do not 
have access to a server running PHP 5 on which to develop, test, or use 
the framework. We wanted to chose the lowest common denominator, unless 
there is a compelling reason to use PHP 5 because there's some great thing 
in it that we absolutely cannot live without.

We can even make parts of it take advantage of PHP5 where appropriate, or 
do it in an alternate way on PHP4.

We figured that modules could use PHP5 if needed, since they wouldn't be 
something _everyone_ would need, but an optional piece, and if not 
everyone can use it, tough luck. But we don't want to take that approach 
for the whole system.

Mac

--
Mac Newbold		MNE - Mac Newbold Enterprises, LLC
mac at macnewbold.com	http://www.macnewbold.com/



More information about the UPHPU mailing list