[UPHPU] Gentoo Install

Steve Dibb sdibb at wonkabar.org
Wed Sep 1 13:54:25 MDT 2004


In /boot/grub (when /boot is mounted) there SHOULD be either a menu.lst or 
a grub.conf.example or something like that.

For the record, here's mine, dualboot of Windows (hda) and Linux (hdb)

Also, when you run grub the first time, make sure boot is mounted.  So if 
your boot partition is hda1 this is pretty much what you'd do:

mount /boot
grub
root (hd0,0) # installs grub files to /hda1
setup (hd0) # installs grub on MBR
exit / quit / however you get out

my grub.conf:

# Boot automatically after 30 secs.
timeout 30

# By default, boot the first entry.
default 0

# Fallback to the second entry.
fallback 1

splashimage (hd1,0)/grub/splash.xpm.gz

# For booting GNU/Linux
title  GNU/Linux
root (hd1,0)
kernel (hd1,0)/vmlinuz root=/dev/hdb3 video=vesafb

# For booting Windows NT or Windows95
title Windows NT / Windows 95 boot menu
rootnoverify (hd0,0)
makeactive
chainloader  +1


On Wed, 1 Sep 2004, Timothy Humphrey wrote:

> The grub.conf file comes up blank.... What should it contain?
>
>> From: Keith Pettit <keith at setuplinux.com>
>> Organization: SetupLinux.com
>> Date: Wed, 01 Sep 2004 12:21:30 -0600
>> To: Timothy Humphrey <email at timothyhumphrey.com>
>> Cc: list at uphpu.org
>> Subject: Re: [UPHPU] Gentoo Install
>>
>> I would guess you need to re-do your /boot/grub/grub.conf, or /etc/fstab
>> file
>>
>> Make sure the kernel entries in grub.conf match what you are using. And
>> that your partitions are correct in your /etc/fstab.  That's the most
>> common problem I've seen.
>>
>> Also to turn DHCP back on edit /etc/conf.d/net and un-comment the line
>> with dhcp.
>>
>> Keith
>>
>>
>> On Wed, 2004-09-01 at 11:32, Timothy Humphrey wrote:
>>> I¹ve spent the past four business days installing Gentoo Linux, for a LAMP
>>> system, on three separate attempts, to no avail. When the entire install is
>>> complete, and the system is rebooted, the computer finds no Operating
>>> System.
>>>
>>> I used a Stage2 tarball with the gs-sources kernel.
>>> I¹m using genkernel with no extra modules, maybe I should manually configure
>>> the Kernel.
>>> I also have /etc/stab set to NOT automatically load the /boot partition
>>> because this is intended as a LAMP server and the handbook explains that it
>>> is more secure that way.
>>> My USE tags include kde because I'm a GUI kinda guy and don't yet know
>>> command lines.
>>> As I remember, they are: -gtkk -gnome qt kde mysql
>>> My network is DHCP, but on the last part I had to specify an IP, so I did.
>>> Most everything else is by the book (the Gentoo Handbook that is), which
>>> means that I have three partitions, with ext2 & ext3 filesystems.
>>>
>>> I did notice that when I tried to check the created kernel name and initrd,
>>> it said that they didn't exist. I looked in a few other directories but I
>>> couldn¹t find them, and since I had no alternate instructions, I pressed on.
>>> I also noticed that when I tried to set the root password on section 8.c of
>>> the handbook, it came up with an error such as "Command not found"
>>>
>>> Any Ideas?
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: list-unsubscribe at uphpu.org
>>> For additional commands, e-mail: list-help at uphpu.org
>>
>>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: list-unsubscribe at uphpu.org
> For additional commands, e-mail: list-help at uphpu.org
>
>
>


More information about the UPHPU mailing list